DirectAdmin: apt libz error

When updating Debian Squeeze on a VPS with DirectAdmin, the following error occurred:

/usr/local/lib/libz.so.1: no version information available (required by /usr/lib/libapt-pkg.so.4.10)
/usr/lib/apt/methods/http: /usr/local/lib/libz.so.1: no version information available (required by /usr/lib/libapt-pkg.so.4.10)

This error is easy to fix by pointing the symlink to the correct file:

rm /usr/local/lib/libz.so.1.2.3
ln -sf /usr/lib/libz.so.1.2.3.4 /usr/local/lib/libz.so.1

Apt: list available upgrades en andere tips

Een server moet worden bijgehouden met de meest recente packages, voor de beste werking maar ook i.v.m. de security. De beschikbare updates kunnen worden geïnstalleerd met:

apt-get upgrade

Wanneer er tools of sites zijn die bepaalde packages gebruiken, is het verstandig om eerst te bekijken welke packages geupgrade worden. Daarom even opgezocht hoe dat gedaan kan worden:

apt-get --just-print upgrade

of

apt-get -s upgrade

Meer handigheidjes van apt zijn hieronder te vinden.
Continue reading Apt: list available upgrades en andere tips