DirectAdmin: apt libz error

When updating Debian Squeeze on a VPS with DirectAdmin, the following error occurred:

/usr/local/lib/libz.so.1: no version information available (required by /usr/lib/libapt-pkg.so.4.10)
/usr/lib/apt/methods/http: /usr/local/lib/libz.so.1: no version information available (required by /usr/lib/libapt-pkg.so.4.10)

This error is easy to fix by pointing the symlink to the correct file:

rm /usr/local/lib/libz.so.1.2.3
ln -sf /usr/lib/libz.so.1.2.3.4 /usr/local/lib/libz.so.1

Leave a Reply

Your email address will not be published. Required fields are marked *